Como Instalar o TP-Link TL-WN822N no Ubuntu

instalar o adaptador wireless tp-link wn822n no ubuntu e mint
Compartilhe:

Você não conseguiu instalar o Adaptador USB Wireless TP-Link WN822N no Ubuntu, aqui está uma forma que encontrei para instalar o driver correto.

1 -No Terminal verifique se há atualizações:

$ sudo apt update 

2 – Depois instale o Git:

$ sudo apt install git 

3 – Faça o download do driver no github:

$ git clone https://github.com/cilynx/rtl88x2bu.git

4 – Vá para a pasta do driver:

$ cd rtl88x2bu

5 – Dentro da pasta compile e instale o driver para o seu kernel:

$ VER=$(sed -n 's/\PACKAGE_VERSION="(.*)"/\1/p' dkms.conf)
$ sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}
$ sudo dkms add -m rtl88x2bu -v ${VER}
$ sudo dkms build -m rtl88x2bu -v ${VER}
$ sudo dkms install -m rtl88x2bu -v ${VER}

6 – Carregue o driver:

$ sudo modprobe 88x2bu

10 – Agora reinicie o sistema

E pronto!!! Agora deve funcionar da maneira correta. Para mim funcionou.

Como Instalar o TP-Link TL-WN822N no Ubuntu

6 pensou em “Como Instalar o TP-Link TL-WN822N no Ubuntu

  1. Olá! Fiz todos os passos certinhos, mas a partir do passo 6 tá dando erro:

    erasmo@erasmo-Inspiron-3421:~/rtl8192eu-linux-driver$ sudo make install
    install -p -m 644 8192eu.ko /lib/modules/5.4.0-48-generic/kernel/drivers/net/wireless/
    install: cannot stat ‘8192eu.ko’: No such file or directory
    make: *** [Makefile:1706: install] Error 1

    erasmo@erasmo-Inspiron-3421:~/rtl8192eu-linux-driver$ sudo modprobe 8192eu
    modprobe: FATAL: Module 8192eu not found in directory /lib/modules/5.4.0-48-generic

    1. Boa tarde Erasmo,

      Desculpe a demora, porque além de muito trabalho, demorei um bocado para achar uma solução.

      Não sei se já solucionou o problema, mas atualizei o post com novos comandos.

      Aqui no meu Ubuntu 20.04 LTS instalou e está funcionado certinho.

      Espero que funcione para você.

  2. Bacana, mas aparentemente não dá para baixar o arquivo .git num pendrive para poder extrair localmente, já que eu não tenho acesso à rede no computador onde preciso fazer esse driver funcionar. Eu tive que andar à pé 4 km para tentar salvar isso num pendrive e voltar para casa, mais 4 km a pé. Seria interessante se esses repositórios que colocam o driver pudesse colocar o arquivo .git para download, ao invés do zip de uma maneira que nem todo leigo consegue compilar. Eu sou esse leigo. Vou continuar tentando uma solução alternativa, antes de voltar para casa com muita frustração.

  3. Desculpe Carlos, mas preciso de ajuda. Estou tentando fazer o TL-WN821N funcionar no meu Ubuntu 18.04 com kernel 4.15, mas seguindo seus passos dá erro no primeiro comando do passo 5:

    VER=$(sed -n ‘s/\PACKAGE_VERSION=”(.*)”/\1/p’ dkms.conf)

    Erro: sed: -e expressão #1, caractere 30: referência inválida \1 no comando RHS `s’

    1. Bom dia Herberto, desculpe a demora, mas realmente estou muito atarefado.
      Quanto ao seu problema isso é questão do kernel. Como uso o Ubuntu 20.04 LTS, o kernel é mais atual, então não ocorre esse problema.
      Já tentei encontrar uma solução para esse erro em um relato anterior, mas até agora não encontrei uma solução. ;(

Deixe um comentário

O seu endereço de e-mail não será publicado.

Rolar para o topo